
# <<YourApp>> Help Index

How To ...
<<add your application-specific "how to" topics here>>

Commands
File menu
Edit menu

             Record menu  
View menu
Window menu
Help menu



File menu commands
The File menu offers the following commands:

New Creates a new document.
Open Opens an existing document.
Close Closes an opened document.
Save Saves an opened document using the same file name.
Save As Saves an opened document to a specified file name.
Delete 
Active File

Deletes the disk file associated with the active window and closes the window 
losing all changes.

Print Prints a document.
Print 
Preview

Displays the document on the screen as it would appear printed.

Page Setup Set up page headers and footers for printing.
Print 
Setup

Selects a printer and printer connection.

Exit Exits EditPro.



Edit menu commands
The Edit menu offers the following commands:

Undo Reverse previous editing operation.
Cut Deletes data from the document and moves it to the clipboard.
Copy Copies data from the document to the clipboard.
Paste Pastes data from the clipboard into the document.

Insert Page 
Break

Inserts a page break at the cursor position.

Find Search document for a text string.
Find Next Repeat the last find.
Replace Search document for a text string and replace it with another text string.
Goto Position the cursor at the specified line (or file position in HEX mode).
Add Indents Presents a dialog to allow adding indentation to selected rows of text.
Remove 
Indents

Presents a dialog to allow removing indentation from selected rows of text.

Hex Edit Toggles the state of the editing mode for the current window between HEX
and ASCII.

Hex 
Insert/Delete

Presents a dialog allowing insertion or deletion of bytes in a file while in HEX
editing mode.



View menu commands

The View menu offers the following commands:

Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.

Toggle 
Bookmark

Toggles a bookmark at the current line.

Next 
Bookmark

Move the cursor to the next bookmark.

Set Font Select the screen font to use.
Set Printer 
Font

Select the printer font to use.

Mirror 
Display Font

Use display font for the printer.

Reset Fonts 
(Default)

Reset the screen and printer fonts to default settings.



Window menu commands

The Window menu offers the following commands, which enable you to arrange multiple 
views of multiple documents in the application window:

Duplicate 
Window

Creates a duplicate window that views the same 
document.

Cascade Arranges windows in an overlapped fashion.
Tile Arranges windows in non-overlapped tiles.
Arrange 
Icons

Arranges icons of closed windows.

Window 1, 
2, ...

Goes to specified window.



Help menu commands

The Help menu offers the following commands, which provide you assistance with this 
application: 

Index Offers you an index to topics on which you can get help.
Using Help Provides general instructions on using help.
About Displays the version number of this application.



New command (File menu)

Use this command to create a new document in EditPro.

You can open an existing document with the Open command.

Shortcuts

Toolbar:
Keys: CTRL+N



Open command (File menu)

Use this command to open an existing document (file) in a new window.    You can open multiple 
documents at once.    Use the Window menu to switch among the multiple open documents.    See 
Window 1, 2, ... command.

This command presents the File Open dialog.    This allows multiple files to be selected and opened at 
one time.

Files may also be opened by dragging them from the File Manager into EditPro's window and dropping 
them. (Releasing the mouse button).

You can create new documents with the New command.

Shortcuts

Toolbar:
Keys: CTRL+O



File Open dialog box

The following options allow you to specify which file to open:
File Name

Type or select the filename you want to open.    This box lists files with the extension you 
select in the List Files of Type box. 

List Files of Type
Select the type of file you want to open:
    *.*

Drives
Select the drive in which EditPro finds the file that you want to open. 

Directories
Select the directory in which EditPro finds the file that you want to open.

Read Only
Check this item to open a file in a read-only manner.    Modifications will be disabled.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 

EditPro allows multiple files to be selected from the file list and opened at one time.    To select multiple 
files,    select the first file from the list, then with the CTRL key pressed, select other files in the list.    When
all files are selected,    select OK and the selected files will be opened.

Files may also be opened by dragging them from the File Manager into EditPro's window and dropping 
them. (Releasing the mouse button).



Close command (File menu)

Use this command to close all windows containing the active document.    EditPro suggests 
that you save changes to your document before you close it.    If you close a document 
without saving, you lose all changes made since the last time you saved it.    Before closing 
an untitled document, EditPro displays the Save As dialog box and suggests that you name 
and save the document.

You can also close a document by using the Close icon on the document's window, as shown 
below:



Save command (File menu)

Use this command to save the active document to its current name and directory.    When 
you save a document for the first time, EditPro displays the Save As dialog box so you can 
name your document.    If you want to change the name and directory of an existing 
document before you save it, choose the Save As command.

Shortcuts

Toolbar:
Keys: CTRL+S



Save As command (File menu)

Use this command to save and name the active document.    EditPro displays the Save As 
dialog box so you can name your document.    

To save a document with its existing name and directory, use the Save command.



File Save As dialog box

The following options allow you to specify the name and location of the file you're about to 
save:
File Name

Type a new filename to save a document with a different name.    A filename can contain 
up to eight characters and an extension of up to three characters. 

Drives
Select the drive in which you want to store the document.

Directories
Select the directory in which you want to store the document.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last four 
documents you closed.    Choose the number that corresponds with the document you want 
to open.



Exit command (File menu)

Use this command to end your EditPro session.    You can also use the Close command on the
application Control menu.    EditPro prompts you to save documents with unsaved changes.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



Undo/Can't Undo command (Edit menu)

Use this command to reverse the last editing action, if possible.      The name of the 
command changes, depending on what the last action was.    The Undo command changes to
Can't Undo on the menu if you cannot reverse your last action.

Shortcuts

Toolbar:
Keys: CTRL+Z or

ALT-BACKSPACE



Redo command (Edit menu)
<< Write application-specific help here. >>



Cut command (Edit menu)

Use this command to remove the currently selected data from the document and put it on 
the clipboard.    This command is unavailable if there is no data currently selected.

Cutting data to the clipboard replaces the contents previously stored there.

Shortcuts

Toolbar:
Keys: CTRL+X



Copy command (Edit menu)

Use this command to copy selected data onto the clipboard.    This command is unavailable if
there is no data currently selected.

Copying data to the clipboard replaces the contents previously stored there.

Shortcuts

Toolbar:
Keys: CTRL+C



Paste command (Edit menu)

Use this command to insert a copy of the clipboard contents at the insertion point.    This 
command is unavailable if the clipboard is empty.

Shortcuts

Toolbar:
Keys: CTRL+V



Toolbar command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the 
most common commands in EditPro, such as File Open.    A check mark appears next to the 
menu item when the Toolbar is displayed.

See Toolbar for help on using the toolbar.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The 
toolbar provides quick mouse access to many tools used in EditPro.

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).

Click To

Open a new document.

Open an existing document.    EditPro displays the Open dialog box, in which you can 
locate and open the desired file.

Save the active document or template with its current name.    If you have not named
the document, EditPro displays the Save As dialog box.

Print the active document.

Display the active document as it will be printed.

Insert a page break character into the file at the cursor position.

Toggle the Word-Wrap mode.

Toggle the HEX/ASCII editing mode.

Remove selected data from the document and stores it on the clipboard.

Copy the selection to the clipboard.

Insert the contents of the clipboard at the insertion point.

Display the find dialog to search for a string.

Repeat the last find command.

Display the find and replace dialog.

Goto the specified line number (or address in HEX mode).



Display about box for EditPro.

Change the mouse pointer to a ? that displays help when clicked on an item.



Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be 
executed by the selected menu item or depressed toolbar button, and keyboard latch state. 
A check mark appears next to the menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.



Status Bar

The status bar is displayed at the bottom of the EditPro window.    To display or hide the 
status bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to 
navigate through menus.    This area similarly shows messages that describe the actions of 
toolbar buttons as you depress them, before releasing them.    If after viewing the description
of the toolbar button command you wish not to execute the command, then release the 
mouse button while the pointer is off the toolbar button.

The middle area of the status bar indicates line number (if enabled) of the cursor in the file, 
the column number, the date and time the active file was last modified (prior to this 
session), and the file size.    For new files the date and time shown is the creation date and 
time.    The file size is updated when EditPro writes any changes to the disk.

The right areas of the status bar indicate which of the following keys are latched down:

Indicator Description
OVR The Overstrike mode is selected.
CAP The Caps Lock key is latched down.



Duplicate Window command (Window menu)

Use this command to open a new duplicate window with the same contents as the active 
window.    You can open multiple document windows to display different parts or views of a 
document at the same time.    If you change the contents in one window, all other windows 
containing the same document reflect those changes.    When you open a duplicate window, 
it becomes the active window and is displayed on top of all other open windows.



Cascade command (Window menu)

Use this command to arrange multiple opened windows in an overlapped fashion. 



Tile command (Window menu)

Use this command to arrange multiple opened windows in a non-overlapped fashion.



Tile Horizontal command (Window menu)

Use this command to vertically arrange multiple opened windows in a non-overlapped 
fashion.



Tile Vertical command (Window menu)

Use this command to arrange multiple opened windows side by side.



Window Arrange Icons Command

Use this command to arrange the icons for minimized windows at the bottom of the main 
window.    If there is an open document window at the bottom of the main window, then 
some or all of the icons may not be visible because they will be underneath this document 
window.



1, 2, ... command (Window menu)
EditPro displays a list of currently open document windows at the bottom of the Window 
menu.    A check mark appears in front of the document name of the active window.    Choose
a document from this list to make its window active.    



Index command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can
jump to step-by-step instructions for using EditPro and various types of reference 
information.    

Once you open Help, you can click the Contents button whenever you want to return to the 
opening screen.



Using Help command (Help menu)

Use this command for instructions about using Help.



About command (Help menu)

Use this command to display the copyright notice and version number of your copy of 
EditPro.



Context Help command 

Use the Context Help command to obtain help on some portion of EditPro.    When you 
choose the Toolbar's Context Help button, the mouse pointer will change to an arrow and 
question mark.    Then click somewhere in the EditPro window, such as another Toolbar 
button.    The Help topic will be shown for the item you clicked.

Shortcut
Keys: SHIFT+F1



Title Bar

EditPro - <filename>

The title bar is located along the top of a window.    It contains the name of the application 
and document.

To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging 
their title bars.

A title bar may contain the following elements:
Application Control-menu button
Document Control-menu button
Maximize button
Minimize button
Name of the application
Name of the document
Restore button



Scroll bars

Displayed at the right and bottom edges of the document window.    The scroll boxes inside 
the scroll bars indicate your vertical and horizontal location in the document.    You can use 
the mouse to scroll to other parts of the document.

The horizontal scroll bar is used to position within the current document. The vertical scroll 
bar is used to change the horizontal viewing area of the document.

The horizontal scroll bar is not shown if WORDWRAP mode is selected.



Size command (System menu)

Use this command to display a four-headed arrow so you can size the active window with the
arrow keys.

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer 

to the border you want to move.    
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or 
dialog box with the arrow keys.

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



#Minimize command (application Control menu)

Use this command to reduce the EditPro window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9



Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title bar.
Keys: CTRL+F10 enlarges a document window.



Next Window command (document Control menu)

Use this command to switch to the next open document window.    EditPro determines which 
window is next according to the order in which you opened the windows.

Shortcut
Keys: CTRL+F6



Previous Window command (document Control menu)

Use this command to switch to the previous open document window.    EditPro determines 
which window is previous according to the order in which you opened the windows.

Shortcut
Keys: SHIFT+CTRL+F6



Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Note:    If you have multiple windows open for a single document, the Close command on the
document Control menu closes only one window at a time.    You can close all windows at 
once with the Close command on the File menu.

Shortcuts
Keys: CTRL+F4 closes a document window

ALT+F4 closes the EditPro window or dialog box



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the 
Maximize or Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to 
or close an application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the 
following options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap and you can see each title bar.    This option 
does not affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not 
affect applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



Ruler command (View menu)

<< Write application-specific help here. >>



Choose Font dialog box

EditPro allows selection of fonts for the screen and printer.    The selection of screen fonts will
also apply to the printer if the Mirror Display Font menu item is checked on the View Menu.    
If this item is not checked,    the printer fonts have been selected independently from the 
screen fonts.

The Font dialog is presented when font selection is selected from the View Menu.    It will be 
presented if either the Set Font or the Set Printer Font is selected.

The Font dialog presents a selection of installed fonts that may be selected    for use.    If the 
fonts are being selected for the printer, only fonts applicable to the printer are available.    
Selection of font and font size is available.



Choose Color dialog box

<< Write application-specific help here. >>



Find command (Edit menu)

This command displays a dialog box for searching the document for the specified text. The 
following search options exist:

Search Direction
The default search direction is down (toward the end of the document). The option to 
search up or down the document is given. If a search has already occurred in the 
document, the default search direction is that of the previous search.

Match Case
By default, the search will not be case sensitive. The option to make the search case 
sensitive is given. If a search has already occurred in the document, the default selection
for case sensitivity is that of the previous search.

To select all text between the cursor position and the search target, hold down the SHIFT key at the time 
the search is started with the FINDNEXT button.

If the editor active window is in HEX mode, an additional option exists:

ASCII
By default, in HEX mode, the search will be for hexadecimal characters.    Optionally the 
find may be configured to search for ASCII characters.

Shortcut
Keys: ALT+F3



Find Next command (Edit menu)

This command repeats the previous FIND command. The next occurrence of the find text will
be found (if present) in the same direction as the previous find command.

To select all text between the cursor position and the search target, hold down the SHIFT key at the time 
the search is started with the FIND NEXT menu item or shortcut key.

Shortcut
Keys: F3

@Normal@



Find dialog box

<< Write application-specific help here. >>



Replace command (Edit menu)

This command displays a dialog box for searching the document for the specified text, and 
replacing it with a different text. The following replace options exist:

Find Next
Find next finds the next occurrence of the specified text.

Replace
Replace finds the next occurrence of the specified text and replaces it with the new text.

Replace All
Replace all finds every occurrence of the specified text and replaces each occurrence with the new 
text.

Match Case
By default, the search will not be case sensitive. The option to make the search case 
sensitive is given. If a search has already occurred in the document, the default selection
for case sensitivity is that of the previous search.

If the editor active window is in HEX mode, the replace command is not available.

Shortcut
Keys: CTRL+R

@Normal@



Replace dialog box

<< Write application-specific help here. >>



Repeat command (Edit menu)

Use this command to repeat the last editing command carried out.    The Repeat menu item 
changes to Can't Repeat if you cannot repeat your last action.

Shortcut
Key: F4



Clear command (Edit menu)

<< Write application-specific help here. >>



Clear All command (Edit menu)

<< Write application-specific help here. >>



Next Pane

<< Write application-specific help here. >>



Prev Pane
<< Write application-specific help here. >>



Modifying the Document

<< Write application-specific help here that provides an overview of how the user should 
modify a document using your application.    

If your application supports multiple document types and you want to have a distinct help 
topic for each, then use the help context i.d. generated by running the MAKEHELP.BAT file 
produced by AppWizard.    Alternatively, run MAKEHM as follows:

makehm IDR_HIDR_,0x2000 resource.h

If the IDR_ symbol for one of your document types is, for example, IDR_CHARTTYPE, then the
help context i.d. generated by MAKEHM will be HIDR_CHARTTYPE.

Note, AppWizard defines the HIDR_DOC1TYPE help context i.d. used by this help topic for the
first document type supported by your application.    AppWizard produces an alias in the .HPJ 
file for your application, mapping HIDR_DOC1TYPE to the HIDR_ produced by MAKEHM for 
that document type. >>





No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.

<< If you wish to author help specific to each message box prompt, then remove the 
AFX_HIDP_xxx values from the [ALIAS] section of your .HPJ file, and author a topic for each 
AFX_HIDP_xxx value.    For example, AFX_HIDP_INVALID_FILENAME is the help topic for the 
Invalid Filename message box. >>





Print command (File menu)

Use this command to print a document.      This command presents a Print dialog box, where 
you may specify the range of pages to be printed, the number of copies, the destination 
printer, and other printer setup options.

Shortcuts

Toolbar:
Keys: CTRL+P



Print dialog box

The following options allow you to specify how the document should be printed:
Printer

This is the active printer and printer connection.    Choose the Setup option to change the
printer and printer connection.

Setup
Displays a Print Setup dialog box, so    you can select a printer and printer connection.

Print Range
Specify the pages you want to print:
All Prints the entire document.
Selectio
n

Prints the currently selected text.

Pages Prints the range of pages you specify in the From and To boxes.
Copies

Specify the number of copies you want to print for the above page range.
Collate Copies

Prints copies in page number order, instead of separated multiple copies of each page.
Print Quality

Select the quality of the printing.    Generally, lower quality printing takes less time to 
produce.



Print Progress Dialog

The Printing dialog box is shown during the time that <<YourApp>> is sending output to the
printer.    The page number indicates the progress of the printing.

To abort printing, choose Cancel.



Print Preview command (File menu)

Use this command to display the active document as it would appear when printed.    When 
you choose this command, the main window will be replaced with a print preview window in 
which one or two pages will be displayed in their printed format.    The print preview toolbar 
offers you options to view either one or two pages at a time; move back and forth through 
the document; zoom in and out of pages; and initiate a print job.



Print Preview toolbar

The print preview toolbar offers you the following options:
Print

Bring up the print dialog box, to start a print job.
Next Page

Preview the next printed page.
Prev Page

Preview the previous printed page.
One Page / Two Page

Preview one or two printed pages at a time.
Zoom In

Take a closer look at the printed page.
Zoom Out

Take a larger look at the printed page.
Close

Return from print preview to the editing window.



Print Setup command (File menu)

Use this command to select a printer and a printer connection.    This command presents a 
Print Setup dialog box, where you specify the printer and its connection.



Print Setup dialog box

The following options allow you to select the destination printer and its connection.
Printer

Select the printer you want to use.    Choose the Default Printer; or choose the Specific 
Printer option and select one of the current installed printers shown in the box.    You 
install printers and configure ports using the Windows Control Panel. 

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the document is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources.    Specify the tray here.

Options
Displays a dialog box where you can make additional choices about printing, specific to 
the type of printer you have selected.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.



Page Setup command (File menu)

<< Write application-specific help here. >>
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Macro menu commands

The Macro menu includes commands that let you record and playback macros, load and/or save a macro.

What is a macro?

A macro is a series of keystrokes or actions that have been 'recorded' in    the order performed. A macro 
allows you to 'record' a series of keystrokes or actions and then 'playback' or repeat the recorded 
keystrokes and/or actions. A macro is typically used to perform a similar set of actions, multiple times on 
each occurrence of a given text string.

For more information, select the Macro menu command name.:

Load a Macro Loads a macro from a file.
Save a Macro Saves a macro to a file.
Record a Macro Starts recording a macro.
Stop Recording a Macro Stops recording a macro.
Playback a Macro Playback a macro.
Playback a Macro 
Multiple Times

Playback a macro a defined number of times.



Options menu commands

The Options menu provides access to items of EditPro that may be configured and saved 
between sessions.    The Options menu offers the following commands:

Disable Line Numbers Disables line number display. This improves speed on large files.
Auto Indent Toggles the state of automatic line indentation for EditPro.
Word Wrap Toggle state of word wrap for the current window.
Generate Backup 
File

Goto line specified (or address if in HEX mode).

Tab Settings Sets the number of spaces to use inplace of a TAB character.



Macro Load (Macro menu)

The Macro Load command presents a dialog box for loading a previously saved macro from a disk file. 
The dialog box allows selection of a file from any file device known to the system. The default file name 
presented is EditPro.MAC, although any filename is acceptable.

When a file is selected for loading, a check is made to ensure the file is a EditPro macro file.



Macro Save (Macro menu)

The Macro Save command presents a dialog box for saving a macro that has been recorded using the 
Macro Record command to a disk file. The dialog box allows selection of a file from any file device known 
to the system. The default file name presented is EDITPRO.MAC, although any filename is acceptable.

This command is available only if a macro has been recorded, or loaded.



Macro Record (Macro menu)

The Macro Record command starts 'recording' keystrokes and actions for later playback. Recording is 
stopped when the Stop Recording menu selection is made. 

Notes for recording macros:

The Macro Record function records all keystrokes and characters typed while recording is selected. All 
keystrokes are recorded, including key combinations that move to end of line, top or bottom of document 
etc. Care should be taken to ensure that when the macro is to be Played back the same keystrokes are 
appropriate.

Mouse motion and scrolling is NOT recorded while recording is selected. All positioning should be 
performed with the keyboard.

Find and Replace is supported while recording is selected. Any find or replace functions will be recorded 
directly as performed. If all, or any occurrences of "FIND" are replaced with "REPLACE" in a file, the 
same action will be performed when the macro is Played back.

Cut, Copy and Paste are also supported while macro recording is selected. Any of these operations will 
be performed dynamically as the macro is Played back. That is to say that if an item is cut while recording
the macro, an item will be cut while playing back the macro based on the selected text at the time the 
macro is being played back. If the selected text is different while playing back the macro, from when the 
macro is recorded, the text cut while playing back the macro will also be different.

This command is not available if a macro record session is already active.



Macro Stop Recording (Macro menu)

The Macro Stop Recording command stops capturing keystrokes and actions that was started when the    
Macro Record function was selected. Once a macro has been recorded and the session has been 
stopped with this command, the macro may be played back by selecting the Macro Play command.

After a macro has been recorded, it may by saved using the Macro Save command.

This command is not available if a macro record session is not active.



Macro Playback (Macro menu)

The Macro Playback command allows a macro that has been recorded with the Macro Record command 
to be replayed. The macro is replayed one time for each invocation of the command. To replay the macro 
multiple times use the Macro Playback Multiple Times command.

This command is not available if a macro record has not been recorded or loaded.



Macro Playback Multiple Times (Macro menu)

The Macro Playback Multiple Times command allows a macro that has been recorded with the Macro 
Record command to be replayed multiple times. A dialog box is presented that prompts the user for a 
number between 1 and 100000 that specifies the number of times the macro should be replayed. To 
replay the macro a single time use the Macro Playback command.

This command is not available if a macro record has not been recorded or loaded.



Word Wrap command (Options menu)

Use this command to automatically wrap words to the next line at the horizontal edge of the 
active window. When active, word wrap will automatically insert a hidden carriage return at 
the end of a line if it will not fit in the displayable area of the window.

If the editor active window is in HEX mode, this command is not available.



About command (Help menu)

Use this command to display the copyright notice and version number of your copy of 
EditPro.



Setting and Moving to Bookmarks (View menu)

EditPro allows you to set a "bookmark" to mark a position in a file. Once a bookmark has been set at a 
line, you may use menu or keyboard commands to move to that line. 

 To set a bookmark:

1. Move the cursor to the line where you want to set a bookmark.
2. From the View menu, choose Toggle Bookmark.

Shortcut
Keys: CTRL+F2

 To move to the next bookmark after the insertion point, choose Next Bookmark from the View menu.

Shortcut
Keys: F2



Automatic Line Indentation (Options menu)

EditPro provides automatic line indentation. This option is toggled on or off by selecting it from the Edit 
menu. When automatic line indentation is enable, EditPro automatically indents a line to match the 
indentation of the previous line. The indentation is performed by inserting spaces into the document.

This option is only active in INSERT mode, not in OVERSTRIKE mode.



Delete Active File command (File menu)

Use this command to close the active document and delete its associated file from the disk. 
This command prompts the user to ensure the file should really be deleted. If the file is 
deleted from the disk, it is no longer available. USE THIS COMMAND WITH CARE.



Hex Mode Editing (Edit menu)

The HEX Edit command selects the editing mode for the active window. The mode is toggled between 
Hexadecimal (HEX) and ASCII. The ASCII mode of editing is typically used for any ASCII (text) based 
files. In the ASCII mode, EditPro allows normal operation of all functions and allows any characters to be 
typed.

The HEX mode of editing is typically used for non ASCII files, or binary files. These files typically contain 
non-printable characters, and are not text files.

The following restrictions apply when HEX mode is selected:

Cut, Copy and Paste is not supported.
Replace is not supported.
Insert mode is not supported.

When the HEX mode of editing is selected for a given window, EditPro splits the screen area into three 
areas as shown:

File Offset: Hexadecimal Representation ; ASCII Representation
000000h: 30 31 32 33 34 35 36 37 38 39 30 31 32 33 34 35  ;123456789012345      

The file offset area shows the current byte offset of the character at the beginning of the line to
form the beginning of the file.

The hexadecimal representation, shows the hexadecimal value of each file byte as a two 
character field, separated from the next byte by a space (' ').

The ASCII representation provides the view of printable characters. Non printable characters 
are shown with a non printable character ('€').

Editing may be performed in the ASCII area, or the HEX area. Positioning from one area to the
other is performed by clicking the left mouse button in the appropriate area. In the HEX area, 
the only valid characters are, 0-9, A-F, and a-f. All other characters are invalid and are ignored.
In the ASCII area, any printable character is valid, and will be accepted with the exception of 
<CR> and ENTER.

Editing in either the ASCII are or the HEX area automatically updates the other area after each
valid character is typed.

All modifications are performed in OVERSTRIKE mode.
To insert or delete characters in HEX mode, use the HEX Insert/Delete selection from the Edit 
menu.

Shortcut
Keys: CTRL+H



Insert/Overstrike Modes

EditPro allows editing in both insert and over strike modes. The mode of operation is indicated in the 
status bar at the bottom of the EditPro window. The insert/overstrike mode is changed with    the INSERT 
key. The mode is toggled when the INSERT key is pressed.

If insert mode is selected, the second area of the status bar is clear, if overstrike mode is selected, the 
second area of the status bar shows 'OVR'.

Insert mode causes a key to be inserted into the document at the position of the cursor. Overstrike mode 
causes the character immediately to the right of the cursor to be overwritten by the new character.

If the editor active window is in HEX mode, the active window is always in overstrike mode.    To insert text
in HEX mode, use the HEX Insert/Delete selection from the Edit menu.
 



Tab Settings (Options menu)

EditPro allows for selection of TAB stops and for TAB characters to be replaced by spaces automatically 
while editing. The tab settings menu item under the edit menu displays a dialog that has two items that 
may be modified.

The first item, if checked instructs EditPro to replace TAB characters with spaces.    If this selection is 
made, the second item allows selection of the number of spaces to use.

The second item specifies the TAB stops, or the number of spaces to use in place of a TAB character.

If the option to replace TABs with spaces is chosen,      EditPro inserts spaces in place of TABS but 
maintains the TAB stop spacing using the number of spaces specified.

EditPro does not replace existing TAB characters that may exist within the document.



Set Font (View menu)

The Set Font menu item presents the Choose Font dialog box that allows selection of 
different fonts and font sizes.    The selection made will apply to the screen fonts and will also
be applied to the printer font if the Mirror Display Font menu item is checked on the View 
Menu.    If this item is not checked,    the printer fonts have been selected independently from
the screen fonts.

Font selections may be reset to default values by selecting the Reset Fonts menu item.

Note:    If the printer does not support the font,    Windows automatically adjusts to the 
closest font.



Set Printer Font (View menu)

The Set Printer Font menu item presents the Choose Font dialog box that allows selection of 
different fonts and font sizes for use by the printer.    The selection made will apply only to 
the printer fonts.    Selection of the printer fonts unchecks the Mirror Display Font menu item 
on the View Menu.    Only fonts applicable to the printer will be available.

Font selections may be reset to default values by selecting the Reset Fonts menu item.



Mirror Display Font (View menu)

The Mirror Display Font menu item instructs EditPro to use the font that is selected for the 
screen on the printer.    This overrides any font selection already made for the printer with 
the Set Printer Font menu item.    



Reset Fonts (Default) (View menu)

The Reset Font menu item instructs EditPro to reset user selections of the screen and printer
fonts to the default settings.    Any user selections of the screen fonts made with the Set Font 
menu item or printer fonts made with the Set Printer Font menu item will be lost.



Add Indents (Edit menu)

The Add Indents menu item presents a dialog that allows the user to specify the number of 
spaces to add at the beginning of each of the selected (highlighted) lines.    EditPro starts 
adding the specified number of spaces to each line beginning with the first highlighted line 
and ending with the last line that has at least one character selected (highlighted).

The Indents will be added to all lines stated above,    irrespective to and indentations that 
may already exist.

To remove indentations, use the Remove Indents menu item on the Edit Menu.



Remove Indents (Edit menu)

The Remove Indents menu item presents a dialog that allows the user to specify the number
of spaces or tabs remove from the beginning of each of the selected (highlighted) lines.    If 
the checkbox specifying removal of all indents is checked, EditPro will remove ALL 
indentation at the beginning of the selected lines.    EditPro starts removing the indents 
beginning with the first highlighted line and ending with the last line that has at least one 
character selected (highlighted).

If no indentation is found at the beginning of a selected line, no changes are made to that 
line.

To add indentations, use the Add Indents menu item on the Edit Menu.



Hex Insert/Delete (Edit menu)

The HEX Insert/Delete command allows the insertion or removal of characters at the current cursor 
position while in the HEX mode.    This command presents a dialog that allows selection to insert or delete
characters and requires the number of characters that are to be inserted or deleted to be specified.

If insert is selected, EditPro will insert the specified number of characters in the file and initialize them to a
hexadecimal value of 20 (ASCII space).    The characters may them be modified as required.

If delete is selected, the specified number of characters will be removed from the file beginning at the 
cursor position.

Shortcut
Keys: CTRL+D



Disable Line numbers (Options menu)

The Disable Line Numbers option allows the line number display in the status bar to be disabled.    Under 
normal circumstances this option should be left unchecked.    For very large files,    file positioning may be 
slowed down while EditPro establishes the line number.    In this case the line numbers may be disabled.

If the option is checked, line numbsers are disabled, if unchecked line numbers are enabled.



Drag and Drop

EditPro supports dragging and dropping files from the File Manager into an open session of EditPro.    
Files may be selected from the File Manager (multiple files may be selected) and dragged into the EditPro
window.    If the mouse button is released with the mouse over EditPro's window the files selected will 
automatically be opened for editing with EditPro.



Command Line Parameters

EditPro supports command line parameters specifing files to be opened.    EditPro allows multiple files to 
be specified in the command line.    Each of the files specified will be opened when EditPro starts up.    
The filenames on the command line should be separated with a space (' ').



Page Setup (File menu)

The Page Setup menu item presents a dialog allowing the user to set up page headers, footers and 
margins for printing.    The page header, if setup, is printed at the top of every page.    The page footer, if 
setup, is printed at the bottom of every page.    If a page footer or header is setup, a single line is printed 
across the page between the header or footer and the text to be printed.

The header or footer may be disabled by selecting the appropriate check box.

The page header and footer may include text defined by the user, and additionally special characters to 
allow the filename, and page numbers to be printed in the header or footer.

The special characters are:

&f This is replaced in the header or footer with the filename.
&p This is replaced in the header or footer with the page number.

Additionally,    the header or footer may include the file date and time or system date and time.    Two radio
buttons allow the selection of either the file date, or the system date to be included in the header or footer.
The radio buttons select the source of the date and time,    additional special characters used in the 
header or footer specify if the date and time are to be printed and what format is used.

The characters used to specify the time and date format are shown below,    the absence of any of these 
characters result in the time and date not being printed.

The formatting codes date and time    are listed below:

Format Description
%a Abbreviated weekday name
%A Full weekday name
%b Abbreviated month name
%B Full month name
%c Date and time representation appropriate for the locale
%d Day of the month as a decimal number (01-31)
%H Hour in 24-hour format (00-23)
%I Hour in 12-hour format (01-12)
%j Day of the year as a decimal number (001-366)
%m Month as a decimal number (01-12)
%M Minute as a decimal number (00-59)
%p Current locale's AM/PM indicator for a 12-hour clock
%S Second as a decimal number (00-59)
%U Week of the year as a decimal number, with Sunday as the first day of the week (00-51)
%w Weekday as a decimal number (0-6; Sunday is 0)
%W Week of the year as a decimal number, with Monday as the first day of the week (00-51)
%x Date representation for current locale
%X Time representation for current locale
%y Year without the century as a decimal number (00-99)
%Y Year with the century as a decimal number
%Z Time zone name or abbreviation; no characters if time zone is unknown
%% Percent sign

Examples:



Date is July, 4th 1994.    Time is 9:00pm
"%X , %x" prints "21:00 , 07/04/94"

Date is July, 4th 1994.    Time is 9:00pm
"%c" prints 07/04/94 21:00

Date is Jan, 10th 1991.    Time is 5:00am
"%A, %B %d, %Y %I:%M%p" prints Tuesday, January 10, 1991    05:00:am

Page Margins
The page margins may be set up in either inches or millimeters (mm).    Each margin, top, bottom, left and
right may be set independently.    The margins are applied before the headers and footers are generated.  
If the printer is set up to have a minimum margin that is greater than the margin selected in EditPro the 
printer margin will be in effect.

Page Break Character
The page break character may be set to any ASCII character.    The page break character defaults to a 
form-feed character ,12 (0C HEX).    This character may be changed if required but should not be set to 
any printable character as a page break will be inserted on every occurrence of this character when 
printing occurs.    It may be desirable to change this character if the font being used does not allow the 
page break character to be seen.



Goto (Edit menu)

The Goto menu item presents a dialog that allows the user to specify the line at which the cursor should 
be positioned.    The cursor is positioned at the line specified and the line is scrolled into view.    If the line 
number is greater than the number of lines in the file, the cursor is positioned at the end of the file.

In HEX mode the goto dialog allows the user to select the offset into the file at which the cursor should be 
positioned.    If the offset is greater than the file size, the cursor is positioned at the end of the file.

Shortcut
Keys: CTRL+G



Insert Page Break (Edit menu)

The Insert Page Break menu item inserts a page break character at the current cursor position.    The 
page break character can be configured in the Page Setup dialog.

When the document is printed,    the page break character is replaced with a page break.    Printing 
continues on the next page following a page break character.



Generate Backup File (Options menu)

The Generate Backup File menu item determines if EditPro will copy the original file to a backup file when
changes are saved.    If this item is checked EditPro will copy the original file to a file with the same name 
and a ".BAK" extension when the file is saved.    If this item is not checked, a backup file will not be 
generated.






